SpiderWeb Browser for OS X 10.6 & 10.7

=========================================================================
SpiderWeb - Modern Old School Styled Browser for Mac OS X 10.6 and 10.7 Lion.
=========================================================================
10.6 Snow Leopard


Video of it running on 10.6

SpiderWeb is built using Mozilla community code

What features are included
=========================================================================

* Tabbed Browsing
* Comprehensive control of Preferences
* Customizable Toolbars
* XUL Overlay and Bootstrap Extension Support
* SeaMonkey (if slightly modified) Theme Support
* Supports Plug-ins
* Open Search Engine Providers

What is not included
=========================================================================

* Digital Rights Management (DRM) such as Encrypted Media Extensions (EME)
* WebRTC
* WebExtensions
* Developer tools
* Lightweight Themes/Toolbar Backgrounds
* Language Packs

Mac OS X 10.6 and above 32-bit download: (2.2.4 updated 10/24/21) 
 
For basic emoji support on 10.6 click here
 
Note: Install this extension to enable web components polyfill needed for github to work.
=========================================================================


These are released "as-is" with the hope that they will be useful.
As such, there is no warranty of any kind.
 
If i never decide to update these again you can always use White Star or Chromium Legacy or Firefox Legacy on 10.7 and above. This version uses patches from parrotgeeks Firefox legacy.

22 comments:

  1. Which plugins/addons are compatible with SpiderWeb?

    ReplyDelete
    Replies
    1. Add-ons/extensions/themes that work with it can be found linked above or here ( https://drive.google.com/file/d/1AvVF2hMkmWYvIDPeIjk40gTchn9NSorI/view?usp=sharing )
      Plugins support includes quicktime, vlc, evernote, flash, etc

      Delete
    2. In my side the url doesn't work ;'(

      Delete
  2. I've tried putting the libc files into users/Library but it still refuses to launch (crashes instantly) I'm on 10.6.8 Snow Leopard.

    ReplyDelete
    Replies
    1. Have a look at this post. It includes pictures. https://forums.macrumors.com/threads/arctic-fox-web-browser-for-10-6-32-64-bit.2133051/page-36?post=28671793#post-28671793

      Delete
    2. UGH! This isn't the first time I've forgotten about /lib/ and put files in the Library instead -_- Thanks a load!

      Delete
    3. No problem. Glad you got it figured out.

      Delete
  3. i downloaded it on osx 10.7.5 i also needed addons like session manager by michael kraft , tab mix plus and speed dial

    ReplyDelete
    Replies
    1. You can try to manually edit them. Extract the .xpi and edit the install.rdf. Use this ID ( 8de7fcbb-c55c-4fbe-bfc5-fc555c87dbc4 ) and set min version to 1.0* and max version to 2.* and save the file then repack the .xpi.

      Delete
  4. Hi
    seeing the doc in two first photo..... you have winamp for mac?

    ReplyDelete
    Replies
    1. Yep. Runs on 10.6 and above. It's not skinnable like the the old windows versions, but it's still a nice player. http://www.mywinamp.com/winamp-for-mac/

      Delete
  5. Great browser for my early 2008 black macbook, i like to use this machine just because its such a beautiful macbook, i patched it up to run 10.8.5 (it syncs with my iphone 6 while lion can't) and i found this browser from a youtuber, and since i installed it, it opens every website without any issue, i hope you keep this browser up to date for as long as you can. Great work sir and thank you for keeping my oldie macbook useable in 2021! Have a great day and stay healthy :)

    ReplyDelete
  6. Dude, you are doing God's Work, hahaha. Thanks!

    ReplyDelete
  7. Thank you so much for your work i'm so happy to use my imac G5 intel 10.7.5
    I have questions (if possible)
    - i'm searching an extension like adblock fpr youtube
    - i try to open the deezer.com website but when i try to login me the page stay at login( i'm not abble to click on icon facebook / google / apple )
    is there someone who can help me ?

    ReplyDelete
    Replies
    1. Give firefox-legacy a try if you're on 10.7.5
      https://parrotgeek.com/dl.php?file=FirefoxLegacy68.12.0p3.zip

      Delete
    2. Oh :)))) thank you so much for the revert
      i just dl it ill keep you in touch :))))

      Delete
    3. you made my day ! this is all i expected : thanks you so much wicknix. So nice for sharing me that i'm so happy

      Delete

Welcome